Introduction to Electronic Service Analyst

Welcome to Electronic Service Analyst (ESA), the premiere vehicle diagnostics tool from PACCAR Inc.

The Electronic Service Analyst (ESA) is a PC-based diagnostic tool similar to CAT ET or Cummins INSITE. ESA communicates over a Data Link Adapter to the NAMUX components. A technician can use ESA to detect fault codes in the components, verify and troubleshoot new electronic instrumentation functionality, flash the control unit, program parameters and diagnose the root cause of the problems using service information on DealerNet.

If this is your first time using the application, please refer to the specific Getting Started instructions. Those instructions will help you connect and validate your software. Otherwise, please click on a link below for more information.

Administration Tools

Monitor Gauges

Simulate Gauges

Diagnostic Trouble Codes

Chassis Specific Configuration

Flashing

Session Logs

Other ESA Information


Getting Started

Electronic Service Analyst cannot be used until the software license has been validated by connecting to DealerNet. Once ESA is licensed, connect to DealerNet to get updates and keep your software current. The update icon will appear when updates are ready for download. Please see the Quick Start Instructions from the kit if you are licensing for the first time or see Licensing for renewal information.

  1. Complete the physical connections between the computer and truck, using the appropriate Data Link Adapter (DLA).
  2. From the toolbar, click Connect (F3) [image] to start the diagnostic session.
  3. Positive connection status is indicated in the lower left status bar of ESA by a "green LED" and the word "connected" [image].

Diagnostic Trouble Codes

Monitor Gauges

Simulate Gauges

Chassis Specific Configuration

Administration Tools

Flashing

Session Logs

How It All Connects


Data Link Adapters

To use ESA, a connection must be made between the computer and the truck. A Data Link Adapter is used to create that connection. Following is a description of the different types of Data Link Adapters.

Note: The USB Link and USB Link Bluetooth data link adapters will communicate with control units which support both the K-Line protocol and the Diagnostic CAN protocol. The ISO Link Adaptor and Wireless Vehicle Link data link adapters will only communicate with control units which support the K-Line protocol.

  • USB Link This connector can be used to connect to the truck and for flashing a Cab Electronic Control Unit (CECU). It is required when the Control Unit communicates using Diagnostic CAN protocol. Communication can be established wired via USB cable or wirelessly via Bluetooth

Nexiq USB Link Adapter.
  • Wireless Vehicle Link This connector can be used to wirelessly connect to the truck.

Nexiq Wireless Vehicle Link.
  • ISO Link Adapter This connector can be used to physically connect to the truck and is required for flashing a Cab Electronic Control Unit (CECU).

Nexiq ISO Link Adapter.
  • Samtec Data Link Adapter This connector can be used to physically connect to the truck at faster speeds. This Data Link Adapter is for internal use only.

Samtec Data Link Adapter.


Connect to Truck (USB Link)

Connect to Truck using USB Link

1. ESA communicates over an USB Link to the Control Unit on the truck. The technician uses ESA to read fault codes stored in the components, verify instrumentation functionality, and diagnose the root cause of the problem using information in the application and on DealerNet.

Nexiq USB Link.

2. | Connect USB Link to truck under dash using the 9-pin deutsche connector - lock in place.
3. Turn the ignition key to the first ON position.

NOTE:
  • Engine doesn't need to be running unless monitoring inputs from engine gauges like the speedometer or oil pressure.
4. | Once all the physical connections (see How It All Connects) are complete between the computer, truck, and USB Link, click the Connect button (F3).

5. The Control Unit Information window is displayed once the conneciton is complete.

6. Once connected, the diagnostic session is ready for use.

Diagnostic Trouble Codes

Monitor Gauges

Simulate Gauges

Chassis Specific Configuration

Administration Tools

Flashing

Session Logs

7. | When you are done using the application, click the Disconnect button (F4) to stop communication.

8. | Detach USB Link from Truck.
Problems connecting?


Connect to Truck (USB Link)

Connect to Truck using USB Link - Bluetooth

1. ESA communicates to the Control Unit on the truck over a wireless Bluetooth device, used in conjunction with an USB Link. This allows the technician to use ESA on a PC located some distance from the truck. The technician uses ESA to read fault codes stored in the components, verify instrumentation functionality, and diagnose the root cause of the problem using information in the application and on DealerNet

Nexiq USB Link.

2. | Connect USB Link to truck under dash using the 9-pin deutsche connector - lock in place.
3. | Connect the Bluetooth device to the PC.
4. Turn the ignition key to the first ON position.

NOTE:
  • Engine doesn't need to be running unless monitoring inputs from engine gauges like the speedometer or oil pressure.
5. | Confirm the Bluetooth device is receiving signals from the USB Link. (Some setup may be required - refer to the USB Link manual).
6. | Once all the physical connections (see How It All Connects) are complete between the computer, truck, USB Link, and Bluetooth, click the Connect button (F3).

7. The Control Unit Information window is displayed once the conneciton is complete.

8. Once connected, the diagnostic session is ready for use.

Diagnostic Trouble Codes

Monitor Gauges

Simulate Gauges

Chassis Specific Configuration

Administration Tools

Flashing

Session Logs

7. | When you are done using the application, click the Disconnect button (F4) to stop communication.

8. | Detach USB Link from Truck.
Problems connecting?


Connect to Truck (Wireless)

Connect to Truck Using Wireless Vehicle Link

1. | ESA communicates over a Wireless Vehicle Link (WVL ) to the Control Unit on the truck. The technician uses ESA to read fault codes stored in the components, verify instrumentation functionality, and diagnose the root cause of the problem using information in the application and on DealerNet.
2. | Connect WVL to truck under dash using the 9-pin deutsche connector – lock in place.
3. Confirm WVL has Power – look for a green power light on the box.

Once connected to the truck, the Wireless Vehicle Link delivers messages between the truck and laptop via a wireless connection.

The WVL and computer are configured to communicate only with each other. It is a peer to peer connection. A network connection is not required.

Nexiq Wireless Vehicle Link.

4. Turn the ignition key to the first ON position.

NOTE:
  • Engine doesn't need to be running unless monitoring inputs from engine gauges like the speedometer or oil pressure.
5. | Once all the physical connections (see How It All Connects) are complete between the computer, truck, and WVL, click the Connect button (F3).

6. A search for active WVL's is performed and the NEXIQ Connection Manager is displayed.
Choose the WVL that you have connected to the truck and click OK.

NOTE:
  • NEXIQ Connection Manager is launched before each connection by default. To change this, uncheck the checkbox at the bottom of the NEXIQ Connection Manager.

  • Each Wireless Vehicle Link is assigned a Device Name. It is a good idea to label the physical Wireless Vehicle Link with the Device Name so that there is no confusion about which Wireless Vehicle Link is being used.

  • An IP address needs to be assigned to the computer that will connect to WVL in the 192.168.1.x range; recommend .101 through .199
Nexiq Connection Manager details available wireless connections.

7. The Control Unit Information window is displayed once the connection is complete.
8. Once connected, the diagnostic session is ready for use.

Diagnostic Trouble Codes

Monitor Gauges

Simulate Gauges

Chassis Specific Configuration

Administration Tools

Flashing

Session Logs

9. | When you are done using the application, click the Disconnect button (F4) [image] to stop communication.

10. | Detach WVL from truck.
Problems connecting?


Connect to Truck (IsoLink)

Connect to Truck using ISO Link

1. ESA communicates over an ISO Link to the Control Unit on the truck. The technician uses ESA to read fault codes stored in the components, verify instrumentation functionality, and diagnose the root cause of the problem using information in the application and on DealerNet.

Nexiq ISO Link.

2. | Connect ISO Link to truck under dash using the 9-pin deutsche connector - lock in place.
3. Turn the ignition key to the first ON position.

NOTE:
  • Engine doesn't need to be running unless monitoring inputs from engine gauges like the speedometer or oil pressure.
4. | Once all the physical connections (see How It All Connects) are complete between the computer, truck, and ISO Link, click the Connect button (F3).

5. The Control Unit Information window is displayed once the conneciton is complete.

6. Once connected, the diagnostic session is ready for use.

Diagnostic Trouble Codes

Monitor Gauges

Simulate Gauges

Chassis Specific Configuration

Administration Tools

Flashing

Session Logs

7. | When you are done using the application, click the Disconnect button (F4) to stop communication.

8. | Detach ISO Link from Truck.
Problems connecting?


Connect to Vehicle (Samtec)

Connect to Vehicle using Samtec

1. ESA communicates over a Samtec adapter to the Control Unit on the truck. The technician will use ESA to read fault codes stored in the components, verify instrumentation functionality, and diagnose the root cause of the problem using information in the application and on DealerNet.

Samtec Data Link Adapter.

2. | Connect Samtec adapter to truck under dash using the 9-pin deutsche connector- lock in place.
3. Turn the ignition key to the first ON position.

NOTE:
  • Engine doesn't need to be running unless monitoring inputs from engine gauges like the speedometer or oil pressure.
4. | Once all the physical connections (see How It All Connects) are complete between the computer, vehicle, and Samtec adapter, click the Connect button (F3).

6. The Control Unit Information window is displayed once the connection is complete.

Control unit information.

7. Once connected, the diagnostic session is ready for use.

Diagnostic Trouble Codes

Monitor Gauges

Simulate Gauges

Chassis Specific Configuration

Administration Tools

Flashing

Session Logs

8. | When you are done using the application, click the Disconnect button (F4) to stop communication.

9. | Detach Samtec adapter from vehicle.
Problems connecting?


Introduction to Electronic Service Analyst

How It All Connects

A low-level view of ESA connections.


Administration Tools

Users can control a variety of custom options via the Administration Tools.

Click Tools from the menu, and select Admin to open the application's administration tools.

  • Change language, session log, proxy and other settings
  • Add links to applications
  • Add links to URLs
  • New, renew application licenses
  • Add, change or reset a password
  • Release or unlock a computer's ESA license key
  • Change the User View
  • Change Factory Settings

To preview any new settings click Apply.
To confirm any new settings click OK.


General Administration Tools

The General tab on the Administration form allows users to change settings regarding language and file server, session log, and manufacturer settings. Click an option below for more detailed instructions.

File Server Setting
  1. Only needed if the site practice is to download software from a local server.
  2. Enter the path to the file server where software updates are located.
  3. Click OK.
Auto detect proxy
  1. By default the program will try to detect your proxy settings for access to program downloads. If problems are encountered with downloads you should uncheck the auto proxy and type in the proxy that is in use at the site (contact local IT support to obtain the proxy information). Check this checkbox to try automatic detection of the proxy settings for internet communications (i.e. access to the dealer net websites, license renewal, etc.).
  2. If unchecked, then you need to enter a proxy address in the Proxy Settings field. If you do not know the proxy address or unsure, leave the checkbox enabled.
  3. Click OK.
Days to Keep Session Log
  1. Type the number of days to store session logs, which lets technicians look up past diagnostic sessions. Recommendation is 30 days. Session log is set to 30 days by default. This can be changed to accomodate the site business needs.
  2. Click OK.
Proxy setting
  1. Contains the HTTP address of the proxy to be used. In order to have access to this field, you need to uncheck the Auto Detect Proxy checkbox.
  2. A correct proxy address if prefixed with "http://" or "https://" and usually contains a port number at the end. Example: "http://mydealership.com:8080" or "https://myproxy.mycompany.com:8080".
  3. Click OK.
Language
  1. Click the dropdown menu and select a language for the application.
  2. Click OK.
Manufacturer
  1. The manufacturer selection drives the look and feel of the application. Click the dropdown menu and select the desired manufacturer. A manufacturer must be selected.
  2. Click OK.

    Note: The manufacturer selection is independent of the cluster manufacturer which is automatically determined by the CU.
DLA
  1. Click the dropdown menu and select the datalink adapter which is in use.
  2. Click the flashing device dropdown menu and select the datalink adapter which to flash with.
    1. If a RP1210 compliant device is selected
    2. Format - DLA Name, Diagnostic CAN channel, Speed, wireless or USB (Driver name)
  3. Click OK.
Protocol
  1. ESA uses Keyword Protocol 2000 to communicate to the ICU and CECU. At this time no action is required.

Administration Form. In this form the administrator can make changes to the ESA application.


License and Password

License and Password

ESA requires periodic license validation to ensure the diagnostic data and application features are updated to the most current versions.
If using ESA on a PC for the first time or the number of days designated by PACCAR has passed since you last connected to DealerNet from ESA, then the license for that machine will have expired. This causes most of the application features to be disabled and you will see the following message when you start ESA.

When the 'License Near Expiration' message appears, click Yes to connect to DealerNet to extend the ESA license.

Clicking Yes on either of the above messages will connect you to DealerNet and will extend a license on the machine (assuming an internet connection is available).

An ESA user can get extension of their ESA license in different ways:

  • Automatic Process: When the user connects to DealerNet using the ‘ESA Home’ or ‘ServiceNet’ links in the ESA left navigation bar, license extension is done automatically. This is the preferred method because all the complexity of the process is handled in the background.
  • Offline Process: If the user finds that the license needs to be extended because it has expired and cannot connect to the internet on the PC (e.g. network card failed, remote location with no internet connectivity, etc.) the user could obtain the license extension two different ways:
    1. Use another PC (if available) with internet connectivity and follow the steps outlined below.
    2. Contact the PACCAR Parts Customer Service help desk and obtain a license extension from a support representative using the steps below

    Use the following instructions to extend a license manually.
    1. Start ESA.
    2. In the ESA application, click Tools and select Admin.
    3. Select the License/Password tab.
    4. Make a note of the Machine Key displayed.
    5. Log on to the DealerNet website on a different machine with an internet connection or contact a person over the phone (a colleague or PACCAR representative) with access to the DealerNet website.
    6. On the DealerNet website, click Service tab, then click the Electronic Service Analyst link on the left. In the webpage displayed, click the Administration link.
    7. On the webpage displayed, on the License Extension tab, enter the Machine Key copied from ESA application into the Key Code field.
    8. Click Generate Code.
    9. Enter the new code generated by the website into New License field in the ESA application.
    10. Click the Set License button.
    11. Click OK.


Reset Password

If the ESA Administration Form is locked or you are unable to access it because of a forgotten password, follow the procedure below to reset the password.

  1. On the left navigation bar click ESA Home to open the ESA website and logon to DealerNet.
  2. On the website displayed, click the Administration link, then click Reset Client Password tab.
  3. Within the application, open the Tools menu and select Reset Admin Password menu command.
  4. Highlight the code in the Machine Key field and copy it into memory (CTRL+C).
  5. On the website, paste the code into the Key Code field (CTRL+V).
  6. Click Reset Password.
  7. Copy and paste the new generated code from the website into the New License field within the application.
  8. Click OK.

NOTE:
  • No Access to DealerNet? You can unlock the Administration form by contacting your ESA support representative.


Add External Applications

The External Applications tab permits a user to add buttons to open external applications in ESA. Once added, icons for those applications will appear in the left navigation bar. If an icon is not specified, a generic icon is used.

  1. In the application, click Tools and select Admin.
  2. Select the External Applications tab.
  3. In the Application Path/URL, browse to the appropriate file location (if local or on the network).

    For example:
    • To add the Calculator browse to (or type) "C:\Windows\system32\calc.exe".
    • In the Application Name field, type the name of the application as it should appear on screen.
    • If you would like to use a custom icon, click the custom radio button.

    • If it is a custom icon, type in a filename path for the icon.
    • Click Add.
    • Click Apply to preview changes.
    • Click OK to confirm changes.
NOTE:
  • Update or delete external applications using the appropriate buttons in this window. Click OK to save changes.

External Applications. In this tab the user can add external applications to the ESA left navigation bar.


Add URL Links

The External Applications tab permits a user to add buttons to open websites in ESA. Once added, icons for those websites will appear in the left navigation bar. If an icon is not specified, a generic icon is used.

  1. In the application, click Tools and select Admin.
  2. Select the External Applications tab.
  3. In the Application Path/URL, type the URL of the desired internet location.

    For example:
    • To add the PACCAR website, copy and paste the following URL address "http://www.paccar.com".

  4. In the Application Name field, type the name of the application as it should appear on screen.
  5. If you would like to use a custom icon, click the custom radio button.

  6. If it is a custom icon, type in a filename path for the icon.
  7. Click Add.
  8. Click Apply to preview changes.
  9. Click OK to confirm changes.
NOTE:
  • Update or delete websites using the appropriate buttons in this window. Click OK to save changes.

External Applications. In this tab the user can add websites to the ESA left navigation bar.


Release License

Your ESA license key is unique to the Dealership location. When ESA needs to be removed from one PC and installed on another in the same dealership location make sure you release the license key before uninstalling the application, using these steps:

  1. In the application, click Tools and click Admin.
  2. Click the Release License Key tab.
  3. Click Release License Key button.
  4. Verify your intent to Release License Key. Click YES.
  5. Log onto DealerNet. Requires user name and password, which should be available from the site DIL administrator.
  6. Click OK.
  7. A message will inform if the release is successful.
  8. Click OK and ESA will shut down automatically.
  9. If the release is not successful, please try again or contact your ESA support representative.

Release License. In this tab the user can release a license key to uninstall ESA from a PC.

Confirmation of a successfully released license.


Views and Modes

INTERNAL ONLY. When the user configures ESA to run in a desired mode and view, ESA features are enabled or disabled based on that configuration. The following steps detail how to select a new mode or view.

Application Views

Internal- In this view, the user has full functionality over ESA including connecting via Samtec and changing of valid chassis # and parameters in bulk (OCP).
External- In this view, the user can monitor, simulate, program chassis parameters and review diagnostic trouble codes from the CECU.
Flashing Station- This view is reserved for flashing Control Units in the factory. Only flashing is allowed in this view.

Modes

Regular- Is the only available mode, currently.
  1. In the application, click Tools and click Admin.
  2. Click the Internal tab.
  3. Click Application View dropdown menu to change the view.
  4. Or, Click Application Mode dropdown menu to change the mode. (Not Available)
  5. Make your selections.
  6. Click Apply.
  7. Click OK.

The Internal tab allows the user to specify Views and Modes to change ESA functionality.


Factory Settings

Settings can be configured for factory specifications.

Auto-Download

By checking this box, ESA will automatically download future chassis files at a user specified time. 3:00AM is the default time until it is changed by the user. To change the download time use the up and down arrows [image] to change the download time.

Range of Days to Download

In this dropdown menu, the user can specify how many days of future chassis files to download. The minimum is one day and the maximum is 10 days. Three is the default. Change this field using the down arrow

Priority for Chassis Download

Using the down arrow [image] the user can set the chassis download priority for ESA to use. The default setting is Local, then download. Further definitions:

Local, then download - ESA looks at the local computer for the chassis files to program, if ESA doesn't find the specific chassis file it is looking for, it goes to the Network and queries the chassis system. This is the fastest option.

Download, then local - ESA queries the chassis system for the most recent bills of materials, downloads them and then runs. If not found it looks at the local computer file for the chassis number. This option provides up to date information on the chassis.

Local only - ESA only looks at the chassis files that have been downloaded previously or loaded directly to the computer. This option allows for work to continue if the Network connection is lost.

Number of Days to Keep Chassis Files

In this field, the user can specify how many days of chassis files to keep. use the up down arrows [image] to change the number of days.

Plant Chassis BOM URL

In this field, the user should enter the URL for downloading chassis files. If this field is left empty, functionality for programming chassis specific parameters is lost. The URL will be plant specific.

EDC URL

In this field, the user should enter the URL for reporting and checkoff. EDC is Electronic Data Collection. The URL will be plant specific.

Connection Options

Internal users get the connection options as auto and manual. When manual option is selected then user gets list of control units which are supported by ESA 4 and user can choose to connect to particular control units. At least one Control Unit must be selected before user clicks on Continue button.
Screenshot of the internal tab in Administration Tools.

Screenshot of the manual connection option


Program Chassis Parameters

Use this option to program chassis specific parameters on the truck's control unit.

  1. Click Connect (F3).
  2. Click Program (F10).
  3. Confirm the chassis number in the Chassis Number field.
  4. Select Value to program by choosing from the drop down menu, typing in a number, etc..
  5. Click [image] to save.

Note:
  • To unlock secured parameters or change restricted parameters, see the section on unlocking parameters.
  • The vehicle must have the parking brake set with the engine off to simulate, program, or flash control units.


Parameters

There are different types of parameters in ESA.

  • General Parameters These parameters can be changed by programming chassis parameters.
  • Secured Parameters These parameters are shown as [image] and can be unlocked by using a key code received from PACCAR. After unlocking the parameters are shown as [image]. To unlock secured parameters, see the section on unlocking parameters.
  • Restricted Parameters These parameters are shown as [image] and are only settable by a key code received from PACCAR. To change restricted parameters, see the section on unlocking parameters.

NOTE:
  • The vehicle must have the parking brake set with the engine off to simulate, program, or flash control units.


Unlock Parameters

Use this option to unlock secured parameters or change restricted parameters .

  1. Click Connect (F3).
  2. Click Program (F10).

  3. Verify that the desired value appears in the VIN/Chassis Number field.
  4. Click Unlock Parameters.

  5. Enter key code supplied by PACCAR.

  6. Click OK.

NOTE:
  • Unlocking a parameter is only valid if a lock symbol ( [image]) is present in the locked column.
  • The vehicle must have the parking brake set with the engine off to simulate, program, or flash control units.


Monitor

Monitor allows the user to monitor dash and interior components from the computer to conduct diagnostics. Other functions include:
  • Select from components to be monitored from the monitor/simulate components list.
  • Customize commonly used component configurations .
  • Choose between a component view or a data view display by using (Ctrl+F7) or clicking Monitor Data View.

  1. Click Monitor [image] to begin. (F7)
  2. In Monitor mode, the user can observe the behavior of the gauges.


Monitor Interior Components

  1. Turn key to first ON position.
  2. Click Connect (F3).
  3. Click Monitor (F7) [image] to watch the gauges and dash telltales activity screen.
  4. Select gauges or dash telltales by checking from the list or select a filter . (see Create a custom filter for gauges or telltales).
  5. Select a Unit of Measure
  6. Click Open the View.

NOTE:
  • Engine doesn't need to be running unless monitoring inputs from engine gauges like the speedometer or oil pressure.
  • User can toggle between a gauge view or a list view by clicking Monitor Data View or Close Data View (F8).
  • You can monitor both metric and standard by clicking the corresponding radio button.


Monitor Data View

Monitor can be displayed in either the component view or a data representation view.

To show data view click [image] or press (Ctrl+F7).

Component View

Screenshot of the component view option in Monitor Mode.

Data View

Screenshot of the data view option in Monitor Mode.


Custom Views

Users may save their own specific configurations, called "Views," these views may be re-used across many trucks.

To create a custom set (view), in Monitor or Simulate mode:
  1. Select components to be saved.
  2. Click Save View.
  3. Type a name for the view in the box.
  4. Click save.
  5. New Component view is now available in the Custom Views dropdown menu.

Screenshot of the view interface found in the Monitor and Simulate modes.

To delete a custom set (view), in monitor or Simulate mode:
  1. Select the custom view to be deleted from the Custom Views dropdown menu.
  2. Click Delete View.
  3. Click yes.

Screenshot of the delete view interface found in the Monitor and Simulate modes.

NOTE:
  • Make the file name something recognizable to all users, describing the components in the custom filter. This avoids duplication of similar configurations.
  • The name given to a view cannot be duplicate of an existing name.
  • The components appearing in the tree are grouped according to the control units.
  • The vehicle must have the parking brake set with the engine off to simulate, program, or flash control units.


VCAN Data Bus Monitoring

V-CAN Data Buses Monitoring and Viewing Data Buses Log Files

The Service Technician can record the message traffic off of the Vehicle CAN data bus via ESA’s Monitor functionality. The message traffic is saved on the user’s computer in a plain-text log file. This log file can be accesses from within the Monitor Data Bus control, from the Tools menu in ESA, and from the ESA Program Files folder in the Windows Start menu.
  1. Open ESA
  2. Click Connect
  3. Click Monitor
  4. Click the Plus in front of the Data Buses group to open it
  5. Click in the box in front of Vehicle CAN to open it to the Monitor Screen
  6. Click Start Recording button to start generating a V-CAN log file
  7. Click Stop Recording button to stop generating a V-CAN log file
  8. Click View Logs button to follow the link to the folder with the Data Bus log files.

NOTE:
  • Each time Start Recording and Stop Recording are clicked, a separate log file is created and saved.

Screenshot of the data buses group.

Screenshot of the Vehicle CAN data bus control check box.

Screenshot of the buttons to start monitoring and view the data bus logs.

Screenshot of the button to stop monitoring.

Screenshot of the window that displays where the data bus log was saved.


VCAN Data Bus Monitoring - Accessing the Logs

Accessing V-CAN Data Bus Log Files from ESA Tools Menu

The vehicle CAN data bus log files can be accessed from the Tools tab in ESA.
  1. Open ESA
  2. Click Tools
  3. Click View Data Bus Logs to follow the link to the folder with the Data Bus log files


VCAN Data Bus Monitoring - Accessing the Logs

Accessing V-CAN Data Bus Log Files from the Windows Start Menu

The vehicle CAN data bus log files can be accessed from Windows.
  1. Click Start in the lower left corner of the PC screen
  2. Click Programs
  3. Click PACCAR
  4. Click Electronic Service Analyst
  5. Click Diagnostic Logs to open the folder with the V-CAN Data Bus log files


Simulate

Simulate allows the user to simulate dash and interior components from the computer to conduct diagnostics. Other functions include:
  • Select from components to be simulated from the monitor/simulate components list.
  • Customize commonly used component configurations .

  1. Click Simulate [image] to begin.
  2. In Simulate mode, the user can send signals to the selected gauges or telltales to verify functionality.

NOTE:
  • The vehicle must have the parking brake set with the engine off to simulate, program, or flash control units.


Simluate Interior Components

Simulate Interior Components

  1. Turn truck ignition to the first ON position.
  2. Click Connect (F3).
  3. Click Simulate (F8) [image] to open the Simulate screen.

  4. Select gauges and/or telltales by checking from the list or select a filter . (Create a custom gauge/tell tale filter).
  5. Select a Unit of Measure. (Not Required)
  6. Use the slider bar or enter a value to manipulate the interior component.

NOTE:
  • Toggling between a gauge view and a data view is not available in Simulate mode.
  • Simulate mode can not be used if engine is running.
  • You can monitor both metric and standard by clicking the corresponding radio button.
  • The vehicle must have the parking brake set with the engine off to simulate, program, or flash control units.


Cluster Test

Users can test if the lights and signals in the dash cluster are functional in Simulate mode.

  1. Click Connect (F4).
  2. Click Simulate (Ctrl+F9).

  3. Select Cluster Test.
  4. Click Start .
  5. To end the test at any time, click Stop in Cluster Test.

NOTE:
  • The vehicle must have the parking brake set with the engine off to simulate, program, or flash control units.


Diagnostic Trouble Codes

Click Diagnose to review Diagnostic Trouble Codes (DTCs) from the truck.
  1. Click Connect (F3).
  2. Click Diagnose (F6).
  3. For a Control Unit that is detected dynamically, a new tabpage will get created which will contain the list of DTCs specific to that Control Unit.
  4. For more details about a DTC, on a truck with a CECU, click the DTCs corresponding

    NOTE:
    • Trucks with Instrument Control Units (ICU) will not display additional details.
  5. List of all available Control Unit's DTCs is shown in "All" tabpage along with the total count of available DTCs.

  6. Count of a single Control Unit DTCs is shown along with the tabpage name, which gets dynamically updated as new DTCs occur.

    7. NOTE:
    • "Source" column will not be available in control unit specific tab.
    • Name of Tab Page shows the abbreviated name for control unit.
    • Tooltip of Tab Page shows the full name of control unit.
  7. Inactive DTC records can be cleared by clicking the [image] button.
  8. Control units have a limited number of DTC records that can be held in memory. If this limit is exceeded, clearing inactive DTCs from the control unit may result in more active DTCs being displayed.
  9. To review set of DTCs specific to control unit click the respective Clear DTCs button.

    10. Screenshot for Clear DTCs Button for Steering Wheel Control Display

    Screenshot for Clear DTCs Button for Cab Electronic Control Unit 3

    Example:
    Clear DTC will clear DTCs from all the control units if user clicks on Clear All DTCs button. Clear DTC button will clear DTCs specific to PACCAR Display if user has selected PACCAR Display tab.


Freeze Frames

Find more detailed information about Diagnostic Trouble Codes (DTCs) using the details option. It records feedback from 5 other components on the truck at the time the fault occured.
  1. Click Connect (F4).
  2. Click Diagnose (F6).
  3. DTCs will be displayed.
  4. To find more detailed information about a DTC click the corresponding magnifying glass located in the 'details' column.
  5. DTC Details screen is displayed.

NOTE:
  • Due to hardware limitations, ICU version of the CU provides limited information.


Print Preview Reports

Printable reports are available for the Control Unit Information, Diagnose, Monitor and Program screens. Each of these screens has a Print Preview button that generates the report. Each report includes the VIN\Chassis number and the date and time the report was generated. These reports can be used to document before and after repair situations for warranty or billing purposes.
  • The Control Unit Information report will display basic information about all control units connected to ESA.
  • The Diagnose report will show the details for all Control Units that have DTCs logged.
  • The Monitor report will display values for all components that are selected.
  • The Program report can be used to document the parameter settings for a vechicle.

  1. Open ESA
  2. Click Connect
  3. Click the Print Preview button
  4. To save the report click the File Save icon, select a file type and follow instructions for saving
  5. To print the report click the File Print icon, select a printer and print

NOTE:
  • Warranty claims reports should be saved in PDF format before submission to PACCAR.

Screenshot of the Print Preview button location for the control unit information.

Screenshot of the Print Preview button location for the diagnose screen.

Screenshot of the Print Preview button location for the monitor screen.

Screenshot of the Print Preview button location for the parameters screen.

Screenshot of the Export Report button on the print preview screen.

Screenshot of the Print Report button on the print preview screen.


Flashing

Flashing is used to get new versions of the vehicle software onto the Control Unit or to replace a defective or non-functional Control Unit.

Flash in the Factory

Flash New Version of Vehicle Software to the Control Unit

Flash and Restore Parameters to a Defective or Non-functional Control Unit

Restore Parameters to the Control Unit

Backup Control Unit Parameters

Download ECAT Chassis File

ECAT Parameters Restore Report

NOTE:
  • The vehicle must have the parking brake set with the engine off to simulate, program, or flash control units.


Flash Control Unit in the Factory

Flash Control Unit in Factory

Flashing can be used to put initial version of the vehicle software onto the Control Unit.
  1. User must change application view to Flashing Station.
  2. Click Connect (F4). .
  3. Click Tools in the menu
  4. Click Flashing.
  5. Click Flash Control Unit.
  6. Type or scan Chassis Number. This will begin the flashing process.
  7. It is important to avoid disconnection and to keep power supplied to the Control Unit to ensure proper flashing.
  8. System displays a progress report of the flashing process.
  9. Control Unit software is updated.
  10. System displays a report of the finished flashing process.

NOTE:
  • The vehicle must have the parking brake set with the engine off to simulate, program, or flash control units.

Screenshot of the factory flashing progress window.

Screenshot of the factory flashing complete message.


Flash New Version of Vehicle Software to the Control Unit

Flashing can be used to put new versions of vehicle software onto the Control Unit.
  1. Keep power on by turning the key to first on position.
  2. Click Tools in the menu
  3. Click Flashing.
  4. Click Flash & Restore Parameters.
  5. It is important to avoid disconnection and to keep power supplied to the Control Unit to ensure proper flashing.
  6. Select the Software version to be flashed to the Control Unit from the list of available versions
  7. System displays a progress report of the flashing process.
  8. Control Unit software is updated.
  9. System displays a report of the finished flashing process.

NOTE:
  • A connection to the truck and power to the control unit must be maintained to ensure complete flashing of the components.
  • The vehicle must have the parking brake set with the engine off to simulate, program, or flash control units.

Screenshot of the menu item to initiate flashing and restoring parameters on a control unit.

Screenshot of the flashing progress window.

Screenshot of the window to select the desired software version to flash on the control unit.

Screenshot of the flashing progress window with the flashing process in progress.

Screenshot of the flashing progress window with the flashing process completed.

Screenshot of the window indicating flashing completed successfully.


Flash a Non-Responsive Control Unit

Flashing can be used to recover a non-responsive Control Unit.
  1. Keep power on by turning the key to first on position.
  2. Click Tools in the menu
  3. Click Flashing.
  4. Click Flash & Restore Parameters.
  5. It is important to avoid disconnection and to keep power supplied to the Control Unit to ensure proper flashing
  6. You will be prompted to either download chassis data from ECAT, Or, flash with System Test Software to determine the available software versions that can be flashed
  7. If you click Yes on a prompt to download chassis data from ECAT, enter the Chassis number and ePortal Logon credentials
  8. If you click Yes on a prompt to flash with System Test Software, wait till System Test Software gets flashed sucessfully
  9. Select the division and the Software Version to be flashed to the Control Unit from the list of available versions
  10. Select the appropriate option from available Restore Parameter Options
  11. System displays a progress report of the flashing process
  12. Control Unit software is updated
  13. System displays a report of the finished flashing process

NOTE:
  • A connection to the truck and power to the control unit must be maintained to ensure flashing completes successfully.
  • The vehicle must have the parking brake set with the engine off to simulate, program, or flash control units.

Screenshot of the menu item to initiate flashing and restoring parameters on a control unit.

Screenshot of the flashing progress window.

Screenshot of the window which prompts for ECAT Chassis Download.

NOTE:
  • If you click No on this prompt, an another prompt will be displayed to flash with System Test Software to determine the available Software Versions that can be flashed.

Screenshot of the window to enter Chassis Number.

Screenshot of the window to enter ePortal logon credentials.

Screenshot of the progrees window for Chassis File Download.

Screenshot of the window showing successfull download of chassis file from ECAT.

Screenshot of the flashing wizard window showing Version Selection options.

Screenshot of the window which prompts for flash with System Test Software.

NOTE:
  • This prompt gets displayed in case you clicked No on a window which prompts for ECAT Chassis Download.

Screenshot of the progress window for flash with System Test Software.

Screenshot of the window indicating successfull flash with System Test Software.

Screenshot of the flashing wizard window showing Version Selection options.

Screenshot of the flashing progress window showing progress for connection to the Control Unit.

Screenshot of the prompt window showing Restore Parameter Options.

Screenshot of the window showing confirmation for Restore Parameters from vehicle software default values.

Screenshot of the window showing progress and status for flash.

Screenshot of the window indicating flashing completed successfully.


Restore Parameters

Restore Parameters can be used to restore parameters to a Control Unit from an existing backup or from an ECAT file.
  1. Keep power on by turning the key to first on position.
  2. Click Tools in the menu
  3. Click Flashing.
  4. Click Restore Parameters.
  5. It is important to avoid disconnection and to keep power supplied to the Control Unit to ensure proper flashing
  6. Select to restore from an existing backup file or from an ECAT chassis file
  7. System displays a progress report of the flashing process
  8. Parameters are restored from a file to the Control Unit
  9. System displays a report of the finished restore parameters process

NOTE:
  • If the Vehicle Software is expired, a forced update will occur during connect.
  • A connection to the truck and power to the control unit must be maintained to ensure parameters are restored successfully.
  • The vehicle must have the parking brake set with the engine off to simulate, program, or flash control units.

Screenshot of the menu item to initiate restoring parameters on a control unit.

Screenshot of the restore parameters progress window.

Screenshot of the window to select which file to restore parameters from.

Screenshot of the window indicating restoring parameters completed successfully.


Backup Parameters

Backup Parameters can be used to back up parameters from a Control Unit for loading to a new Control Unit.
  1. Keep power on by turning the key to first on position.
  2. Click Tools in the menu
  3. Click Flashing.
  4. Click Backup Parameters.
  5. It is important to avoid disconnection and to keep power supplied to the Control Unit to ensure proper flashing
  6. System displays a progress report of the backup parameters process
  7. Parameters are backed up from the Control Unit to a file on the local computer
  8. System displays a report of the finished backup parameters process

NOTE:
  • If the Vehicle Software is expired, a forced update will occur during connect.
  • A connection to the truck and power to the control unit must be maintained to ensure complete flashing of the components.
  • The vehicle must have the parking brake set with the engine off to simulate, program, or flash control units.

Screenshot of the menu item to initiate backing up parameters on a control unit.

Screenshot of the back up parameters progress window.

Screenshot of the window indicating backing up parameters completed successfully.


Flash New Version of Vehicle Software to the Control Unit

Download ECAT chassis parameter files for restoring parameters to a Control Unit

The original (as-built) parameter configuration for a chassis can be downloaded from PACCAR ECAT to the local computer. This file can be used for restoring parameters to a Control Unit. The downloaded file(s) will be stored in the local computer
  1. Identify chassis number(s) for ECAT chassis parameter files to be downloaded
  2. Click Tools
  3. Click on Retrieve Parameters from ECAT
  4. Enter chassis number(s) to be downloaded into the entry box
  5. Click OK
  6. Enter your ePortal Username and Password
  7. Click OK
  8. A progress bar will run during the download process. A "Download complete" message will be displayed when the download is complete, showing the number of chassis parameter files downloaded
  9. Click OK in the "Download complete" message

NOTE:
  • One or more chassis numbers can be entered and downloaded at a time. Separate individual chassis numbers with a comma "," or, enter a contiguous range of chassis numbers by entering the first and last chassis numbers separated by a hyphen "-".
  • The vehicle must have the parking brake set with the engine off to simulate, program, or flash control units.

Screenshot of the retrieve ECAT parameters menu item.

Screenshot of the ECAT chassis number entry box.

Screenshot of the ePortal login box.

Screenshot of the progress screen.

Screenshot of the download complete message.


ECAT Parameter Restore Report

A report is available for comparing the programmed parameters on a truck Control Unit to the as built parameters in the eCAT chassis file. Generation of this report is optional and is created when the ECAT Parameter Restore report button is selected during a restore of the as built parameters from ECAT. This report can be generated any time restoring from ECAT is selected.
  1. Keep power on by turning the key to the first on position.
  2. Click Tools
  3. Click Flashing
  4. Click Restore Parameters
  5. Do not disconnect the Control Unit during this process.
  6. Select Restore parameters from a file downloaded from ECAT
  7. ESA displays a Restore Parameters from ECAT dialog box.
  8. Click on the View eCat File button.
  9. ECAT Parameters Report compares the current parameter settings on the control unit with the parameter settings taken from the ECAT chassis file.
  10. The report can be printed or saved as a file. Close the report when you are done reviewing the report.
  11. Click Cancel to cancel the parameter restore or click OK to continue restoring the parameters from the ECAT chassis file.

NOTE:
  • If the Control Unit on the truck is defective or non-functional, information for some or all of the as-is Control Unit parameters may be missing.
  • The vehicle must have the parking brake set with the engine off to simulate, program, or flash control units.

Screenshot of the menu item to restore parameters.

Screenshot of the restore parameters progress bar.

Screenshot of the option to choose to restore parameters from an ECAT file.

Screenshot of the button to open the ECAT parameters restore report.

Screenshot of an example report. Differences between the parameters in the ECAT file and on the control unit are highlighted in yellow.


View Session Log

The session log is a PC specific record of ESA activities and events. By default ESA will log activities and events for 30 days, but this value can be customized by revising 'Days to Keep Session Log' in General Administration Tools.

  1. To open the session log, click Tools then click View Session Log.
  2. Using the fields available enter Session Log Filters to set the criteria for the search.
  3. Click Generate Report or push enter.
  4. The resulting report will open in the display window at the bottom of that screen. This report can be browsed, exported or printed.

NOTE:
  • Make sure that the start and end date/time fields are set to the desired range before submitting your search of the session log. This value is defaulted to report for events occuring in the previous 20 minutes.


Session Log Filters

Session Log Filters can be set to customize the viewable information in a generated report. Use the filters provided in the session log to specify the amount of information you want to review.

Screenshot of the Session Log Filters.

Time Range

Select a preset range or create a custom range for reporting ESA events. The default setting is to report the events that occured in the previous 20 minutes. Change the time range by clicking a different radio button, or use the up and down arrows on the keyboard.

Preset Range- The built-in ranges are: 20 minutes, 24 hours or 30 days. 20 minutes is the default.
Specify Exact Dates/Times- Specific dates and times can be inputted for the range.

Keyword Search

Use the drop-down menu to select a commonly searched event or enter your own search words.
Note: Wildcards functions can be used to search more effectively:

    Examples:

    vehicle* - This will find all results that contain the word "vehicle", but because of the "*", it will also find "vehicles".

    "chassis number"- This will find only results with the word chassis followed by the word number. Without the quotes, all results containing either word will be included.

Event Class

This provides a way to sort using specific event criteria.

Chassis Number

Type in a chassis number in this field for events related to that specific chassis.

View By

Provides sorting based on type of function.

    Application- Events only related to the ESA application will be displayed.
    System- Events only related to the user's computer and operating system will be displayed.
    Vehicle Communication- Events only related to the vehicle communication will be displayed.
    Internet- Events only related to the Internet and WebServices will be displayed.
    All- All events.

Sort By

Report can be sorted by chassis number or date/time. To change the criteria, select from the drop-down menu.


Export Session Log

Session Logs can either be printed or exported to a particular format (.rpt, .pdf, .xls, .doc, .rtf).

To Export

  1. Generate a report.
  2. Click [image] to export the session log report.
  3. Select a location for file save.
  4. Name the file.
  5. Select a file format from the Save as type: dropdown menu. Adobe Acrobat (.pdf) is recommended.
  6. Click Save.

To Print

  1. Generate a report.
  2. Click [image] to print the session log report.
  3. Follow printing directions.


Other ESA Information

Please click on a link below for more information.

Change Themes

Control Unit Information

Download Software Updates

Emulation Mode

Hot Key List

How It All Connects

How to Order

Print Preview Reports

Sample of Diagnostics Procedure

Troubleshooting

Uninstall ESA

Additional Support: Contact your ESA support representative.


Download Software Updates

Users will be alerted by ESA when updates are available for the application.

  1. If you see this button [image] in the upper right of the ESA screen, application downloads are waiting.
  2. Click the button to initiate downloading.
  3. Click Yes to start the download. Follow the on-screen instructions to complete installation(s).

NOTE:
  • An internet connection is required to receive downloads. For example, when you connect to ServiceNet, ESA checks for updates in the background.
  • We recommend you to connect once every week for updates.
  • If you have passed the required update time period, a forced update will occur during ESA startup. If the forced update is cancelled, ESA functionality will be suspended until updates are completed.


Uninstall ESA

NOTE:
  • When uninstalling ESA and moving the application to another PC you must first release the license key.
  • Uninstalling ESA requires administrative rights to the PC.

  1. Click Start/Control Panel/Add or Remove Programs.
  2. Click Electronic Service Analyst.
  3. Click Remove.
  4. Click OK to verify your intent to remove ESA.
  5. ESA program has been uninstalled.


ESA Hot Key List

F1: Help

F3: Connect

F4: Disconnect

Ctrl+F4: Closes Active Window

F6: Opens the DTCs window (Diagnose)

F7: Opens Monitor window

Ctrl+F7: Changes monitor view from image to data view

F8: Opens Simulate window

F9: Select component

F10: Opens Program window

F12: Toggles user between the toolbar and left navigation bar.

Ctrl+Shift+R: Programs components

Standard Windows shortcut keys apply for navigation:

Tab: Advances to next field

Ctrl+Tab: Switches between windows

Alt+Tab: Tabs between open applications

Tip: You must be Connected (F3) to use features of ESA other than Help (F1).
Close windows using the close button or ctrl+F4.


Control Unit Information

Follow these steps to display control unit information.
  1. Once connected, click Tools in the menu bar.
  2. Click Control Unit Information.
  3. For each Control Unit that is detected, the control unit information is displayed in a separate tab.

The Control Unit Information screen provides information that is vital for troubleshooting.


Emulation Mode

Emulation mode is a feature of ESA that allows a user to learn the functionality of ESA without communicating with a real truck. ESA will emulate the communication with a Control Unit. Emulation mode can be used as a training tool. Since Emulation mode does not run the ESA functions against an actual Control Unit, it can be run without attaching the PC to a truck.
  1. Open ESA
  2. Click Tools
  3. Click Admin
  4. On the General tab, select one of the emulators from the DLA drop down box (CECU3 - P30-1011 Emulator, CECU3 - P30-1009 Emulator, CECU Emulator, or ICU Emulator)
  5. Click Connect
  6. Click OK on the Emulation Mode message
  7. The Control Unit Information Screen opens with clear indications that the user is in Emulation mode. The Chassis and VIN numbers are not valid.
  8. Use ESA as if you were connected to a real truck.
  9. Indications that the user is Emulation mode will display throughout ESA.
  10. Click Disconnect to disconnect from the emulated truck.

NOTE:
  • Emulation mode can be run while attached to a truck, but it will have no impact on the control unit in the truck. DTCs cleared or parameters changed while in Emulation mode will return to their original state after disconnecting. Flashing can also be performed in Emulation mode with no impact on an actual control unit. Be sure to change the DLA back to the DLA you are using with ESA on a truck.
  • CECU3 - P30-1011 Emulator simulates NAMUX 4 and CECU3 - P30-1009 Emulator simulates NAMUX 3.

Screenshot of the list to select an emulator from.

Screenshot of the warning message displayed when connecting to an emulator.

Screenshots of a ESA indicating that it is in emulation mode.


Change Themes

Change the screen image by selecting a manufacturer and changing the theme.
  1. Open ESA
  2. Click Tools
  3. Click Admin
  4. Select the appropriate manufacturer using the drop down list box next to Manufacturer.
  5. Click OK
  6. Click Tools
  7. Click Change Theme
  8. Select a theme by clicking on the image.
  9. Click OK


Sample of Diagnostics Procedure

Primary Air Pressure Gauge isn’t working right
  1. Look to see if the Primary Air Pressure is sending fault codes to ESA (Diagnose)
  2. Watch the Primary Air Pressure gauge in action on the dash (Monitor)
  3. Send signals to the Primary Air Pressure gauge (Simulate)

Customer wants the optional Pyrometer (Exhaust Temperature) checked out
  1. Check to see if gauge is enabled or active (Program)
  2. Watch the Exhaust Temperature gauge in action on the dash (Monitor)
  3. Send signals to the Exhaust Temperature gauge (Simulate)


Troubleshooting

General Connectivity:

Check the ignition key and the connections
  1. Make sure the ignition is turned to the first ON position.
  2. Check the connections. See How It All Connects.
  3. Click Connect.

Connection Setting
  1. Click Tools and select Admin.
  2. In the DLA field, select the appropriate datalink adapter.
  3. Click OK.

Check the Cable
  1. Only use the 9 pin deutsche connector.
  2. See the section on Data Link Adapters for more detail.

Wireless Connectivity:

Check the Wireless Vehicle Adapter
  1. Open Start..., Programs, and select NEXIQ WVL.
  2. Select Connection Manager.
  3. The screen will show all wireless datalink adapters in the work area.
  4. Choose the WVL that you have connected to the truck.
  5. Click OK.
  6. Start ESA and connect.
If this problem persists, see the NEXIQ WVL User's Guide.

Check Wireless Connectivity Settings
  1. For additional information on wireless connectivity and configuration, refer to the ESA installation guide provided in your kit or DealerNet.
  2. See the section on Data Link Adapters for more detail.

Check for Fault Light
  1. Check the Wireless Vehicle Adapter for a red fault light. This indicates a faulty connection from the Wireless Vehicle Adapter to the Truck.
  2. See the section on connecting to the vehicle (Wireless) to make a successful connection.

System Compatibility:

Check for NAMUX compatibility with ESA
  1. To check if truck has NAMUX compatibility, attempt to connect to the truck through ESA.
  2. If ESA is able to connect, the truck has NAMUX compatibility.
  3. If unable to connect, please contact your ESA support representative for further assistance.

Control Unit Information:

Find Control Unit Information
  1. Follow these steps to display control unit information:
  2. Once connected, click Tools in the menu bar.
  3. Click Control Unit Information.
  4. For each Control Unit that is detected, the control unit information is displayed in a separate tab.


How to Order

New ESA kits and replacement parts are available through the PACCAR Parts Dealer Order Entry (DOE) system:

  1. Log on to DealerNet.
  2. Click Parts tab, click Product Documentation link, then Product Index.
  3. Click P for PACCAR Diagnostic Tools.
  4. Click the link next to PACCAR Diagnostic Tools.


Glossary

CECU
Cab Electronic Control Unit. A device located in the cab that receives signals from switches and sensors, controls instruments, telltales and interior lights, and transmits control and status information the other control units on the vehicles' data links. New for NAMUX 2.
CECU 3
Cab Electronic Control Unit, version 3, used to store and report cab electronic DTCs, allows for monitoring and simulating of gauges, and allows ESA to communicate with other control units.
Chassis Node
A slave control unit to the CECU3. It is mounted on the chassis frame and manages inputs and output data for components located outside of the cab such as exterior lighting or axle oil temperatures.
Chassis Number
PACCAR's unique identifier for a vehicle.
Connect
This sends a message to the vehicle's control unit, ensuring information can be properly exchanged.
Control Unit
The control unit is a device located in a vehicle that stores data about the vehicle and its functions.
Control Unit Information
Specific information about the control unit. Including: type, software version and hardware version.
Custom Filter
A customized list gauges or dash tell tales selected and saved for easy re-use.
Data Link Adapter
The physical device that connects the vehicle CU and the diagnostic tool.
DealerNet
Formerly known as Dealerville, DealerNet comprises PACCAR extranet, the deaer DMZ and dealer connections.
DTC
Diagnostic Trouble Code. A code stored on the control unit and transmitted to the diagnostic tool to alert a technician to abnormal conditions on the truck.
Diagnostic Trouble Code
DTC. A code stored on the control unit and transmitted to the diagnostic tool to alert a technician to abnormal conditions on the truck.
Disconnect
This button ends the communication between the computer software and vehicle computer unit.
Driver and Passenger Door Controls
The door controls system allows the driver or passenger to raise or lower the door windows, lock or unlock door locks, adjust mirror position, and activate mirror heat.
Flashing
Downloading software and parameters into the electronic control unit.
Freeze Frame
A snap shot of five components' states when a DTC occurs. Show under the details column of the Diagnose feature of ESA.
HVAC
This is the control unit responsible for Heating Ventilation and Air Conditioning.
ICU
Instrument Control Unit. A device located in the cab that receives signals from switches and sensors, controls instruments and telltales, and transmits status information the other control units on the vehicles' data links. Part of NAMUX 1.
Instrument Cluster
Cluster assembly that contains the speedometer, tachometer, telltale lights, and 5” multi-color driver information screen.
ISO Link Adapter
A wired device used to connect ESA to the truck.
Monitor
In this option, the computer interior component illustrations emulate what's being displayed on the interior components.
PACCAR Display
An in-dash display and head unit that combine to serve as an infotainment product that can be integrated in PACCAR vehicles with features that greatly enhance the commercial vehicle ownership and operating experience. This unit is marketed under the name of SmartNav for Peterbilt and NavPlus for Kenworth.
Parameter
Parameters are values that are stored in the flash memory of an electronic control unit on the truck that direct the software to respond in a manor suited to customer desire, vehicle configuration or operating condition.
Part Number
Unique identifying code for a specific PACCAR part.
Radio
This radio has the ability to communicate and be controlled via J1939 messages and will be used in conjunction with the Rear Sleeper Audio Controller and Steering Wheel Controls.
Samtec Adapter
A wired device used to connect ESA to the truck. This DLA is primarily used in the factory.
ServiceNet
Web-based application that presents documentation of service bulletins and related schematics.
Session Log
Data the diagnostic tool records while it is being used to service a vehicle.
Simulate
In this option, use the computer to command the vehicle's dashboard gauges.
Steering Wheel Controls
Steering wheel with embedded switches used to control other cab functions; primarily radio controls and cruise control.
Telltale
Telltale displays the current status of the component in the form of a warning light or warning lamp. Telltales may be either on a gauge face or on the dash.
Value
The range function that can be assigned to a parameter.
Vehicle Software
Software that is run on the Control Unit. Updates of the Vehicle software may be ‘flashed’ onto the Control Unit.
Vehicle Software Version
The version of software running on the Control Unit.
WVL
A wireless device used to connect ESA to the truck.


Contact PACCAR

Contact PACCAR for Assistance

For assistance with Electronic Service Analyst, including DealerNet connectivity, please contact: PACCAR Parts Customer Service and press # for NBI and ESA support.


Print Diagnostic Trouble Codes

Print a list of Diagnostic Trouble Codes by:
  1. Open the Diagnostic Trouble Codes screen.
  2. Push the print screen key on your keyboard.
  3. Open an external application (i.e. Microsoft Word).
  4. Paste image into external application using Ctrl+V or by clicking Edit > Paste.
  5. Print page using external application Ctrl+P or by clicking File > Print


Replace Control Unit

In the event of a damaged or non-functional Control Unit and if replacing the CU is necessary, follow these steps:
  1. Click Connect (F3). .
  2. Click Tools in the menu
  3. Click Flashing.
  4. Click Replace Control Unit.
  5. It is important to avoid disconnection and to keep power supplied to the Control Unit to ensure proper flashing.
  6. Click Backup Parameters. Note: If a backup file already exists, you will be prompted to confirm overwrite of the previous file.
  7. System displays a progress report of the backup process.
  8. System displays a confirmation of backup.
  9. Click Flash and Restore Parameters. This will begin the flashing process.
  10. System displays a progress report of the flashing process.
  11. Control Unit software is updated.
  12. System displays a report of the finished flashing process.

Screenshot of the restore parameters progress window.

Screenshot of the flashing progress window.

Screenshot of the flashing complete message.


.topic 3000
Connect now to PACCAR

.topic 3001
Disconnect now from PACCAR

.topic 3002

.topic 3003
"To be defined"

.topic 3004
"To be defined"

.topic 3005
"To be defined"

.topic 3006
"To be defined"

.topic 3007
"To be defined"

.topic 3009
"To be defined"

.topic 3012
"To be defined"